File System (CIFS)

This guide shows how to use the Cisco IOS file system, how to interact with the device memory, exchange files with other devices and automatic configuration backups.

Flash Directory

Cisco IOS uses a hierarchical file system (CIFS), which means that files are organized in a tree-like structure, with directories as the branches and files as the leaves. The root directory is the top level of the file system and contains all other directories and files. Cisco IOS supports several types of file systems, including flash file systems, which are used to store files on flash memory devices, and network file systems, which are used to access files stored on remote servers. Cisco IOS also supports file system protocols such as FTP (File Transfer Protocol) and T FTP (Trivial File Transfer Protocol), which allow the user to transfer files to and from the device over a network. In addition to the file system, Cisco IOS also includes tools for managing and manipulating files, such as the "dir" and "copy" commands, which allow the user to list the files in a directory and copy files to and from different locations.

Description
Display the file directory
Display the flash file directory
Display the flash file directory and sort the content by name
Display the flash file directory and sort the content by size
Display the system file directory
Display the non volatile RAM file directory
Display the flash file directory
Display the flash file directory and sort the content by name
Display the flash file directory and sort the content by size
Display the flash file directory and sort the content by date
CLI Commands
dir
dir flash:
dir flash: namesort
dir flash: sizesort
dir system:
dir nvram:
show flash:
show flash: namesort
show flash: sizesort
show flash: timesort
-
-
dir

Switch#dir
Directory of flash:/

688131  -rw-          2097152   Feb 1 2023 07:53:06 +01:00  nvram_config_bkup
688130  -rw-          2097152   Feb 1 2023 07:53:06 +01:00  nvram_config
49153   drwx             4096  Jan 31 2023 08:54:22 +01:00  .installer
688133  -rw-                0  Jan 31 2023 08:50:57 +01:00  dope_hist
688149  -rw-            16976  Jan 31 2023 08:50:57 +01:00  rdope_out.txt
688151  -rw-               89  Jan 31 2023 08:50:55 +01:00  rdope.log
688152  -rw-              916  Jan 31 2023 08:50:39 +01:00  vlan.dat
65537   drwx             4096  Jan 31 2023 08:50:33 +01:00  .prst_sync
688145  -rw-          5242880  Jan 31 2023 08:50:13 +01:00  ssd
688148  -rwx             2049  Jan 31 2023 08:49:57 +01:00  svl_ipc.tcl
688147  -rw-           134458  Jan 31 2023 08:49:57 +01:00  memleak.tcl
688132  -rw-              382  Jan 31 2023 08:49:44 +01:00  boothelper.log
106528  drwx             4096  Jan 31 2023 08:49:42 +01:00  dc_profile_dir
688144  -rw-              259  Jan 31 2023 08:49:33 +01:00  bootloader_evt_handle.log
688158  -rw-             7716  Jan 31 2023 08:29:44 +01:00  packages.conf
114703  -rw-         47422238  Jan 31 2023 08:28:37 +01:00  cat9k-rpboot.17.03.06.SPA.pkg
114702  -rw-             9220  Jan 31 2023 08:27:38 +01:00  cat9k-wlc.17.03.06.SPA.pkg
114701  -rw-         14500868  Jan 31 2023 08:27:38 +01:00  cat9k-webui.17.03.06.SPA.pkg
114700  -rw-         30237704  Jan 31 2023 08:27:38 +01:00  cat9k-srdriver.17.03.06.SPA.pkg
114699  -rw-         57226244  Jan 31 2023 08:27:38 +01:00  cat9k-sipspa.17.03.06.SPA.pkg
114698  -rw-         34980872  Jan 31 2023 08:27:38 +01:00  cat9k-sipbase.17.03.06.SPA.pkg
114697  -rw-        598078468  Jan 31 2023 08:27:38 +01:00  cat9k-rpbase.17.03.06.SPA.pkg
114696  -rw-             5124  Jan 31 2023 08:27:38 +01:00  cat9k-lni.17.03.06.SPA.pkg
114695  -rw-          2262024  Jan 31 2023 08:27:38 +01:00  cat9k-guestshell.17.03.06.SPA.pkg
114694  -rw-        104670216  Jan 31 2023 08:27:38 +01:00  cat9k-espbase.17.03.06.SPA.pkg
114693  -rw-         18449420  Jan 31 2023 08:27:38 +01:00  cat9k-cc_srdriver.17.03.06.SPA.pkg
49156   drwx             4096  Jan 31 2023 08:24:07 +01:00  pnp-tech
49155   drwx             4096  Nov 23 2021 09:01:20 +01:00  .dbpersist
49163   drwx             4096  Nov 23 2021 08:56:07 +01:00  Apps
688154  -rw-             1440  Nov 23 2021 08:54:37 +01:00  2021_11_23T07_54_28.677019.xml
57345   drwx             4096  Nov 23 2021 08:49:08 +01:00  core
196609  drwx             4096  Nov 23 2021 08:48:51 +01:00  guest-share
188417  drwx             4096  Nov 23 2021 08:48:48 +01:00  pnp-info
163841  drwx             4096  Nov 23 2021 08:48:48 +01:00  onep
147457  drwx             4096  Nov 23 2021 08:43:02 +01:00  Tbot
106530  drwx             4096  Nov 23 2021 08:42:54 +01:00  sys_report
106497  drwx             4096  Nov 23 2021 08:42:53 +01:00  tech_support
65540   drwx             4096  Nov 23 2021 08:42:53 +01:00  gs_script
90113   drwx             4096  Nov 23 2021 08:42:51 +01:00  ss_disc
81921   drwx             4096  Nov 23 2021 08:42:46 +01:00  .rollback_timer

11353194496 bytes total (9614319616 bytes free)
Switch#
dir flash:

Switch#dir flash:
Directory of flash:/

688131  -rw-          2097152   Feb 1 2023 07:53:06 +01:00  nvram_config_bkup
688130  -rw-          2097152   Feb 1 2023 07:53:06 +01:00  nvram_config
49153   drwx             4096  Jan 31 2023 08:54:22 +01:00  .installer
688133  -rw-                0  Jan 31 2023 08:50:57 +01:00  dope_hist
688149  -rw-            16976  Jan 31 2023 08:50:57 +01:00  rdope_out.txt
688151  -rw-               89  Jan 31 2023 08:50:55 +01:00  rdope.log
688152  -rw-              916  Jan 31 2023 08:50:39 +01:00  vlan.dat
65537   drwx             4096  Jan 31 2023 08:50:33 +01:00  .prst_sync
688145  -rw-          5242880  Jan 31 2023 08:50:13 +01:00  ssd
688148  -rwx             2049  Jan 31 2023 08:49:57 +01:00  svl_ipc.tcl
688147  -rw-           134458  Jan 31 2023 08:49:57 +01:00  memleak.tcl
688132  -rw-              382  Jan 31 2023 08:49:44 +01:00  boothelper.log
106528  drwx             4096  Jan 31 2023 08:49:42 +01:00  dc_profile_dir
688144  -rw-              259  Jan 31 2023 08:49:33 +01:00  bootloader_evt_handle.log
688158  -rw-             7716  Jan 31 2023 08:29:44 +01:00  packages.conf
114703  -rw-         47422238  Jan 31 2023 08:28:37 +01:00  cat9k-rpboot.17.03.06.SPA.pkg
114702  -rw-             9220  Jan 31 2023 08:27:38 +01:00  cat9k-wlc.17.03.06.SPA.pkg
114701  -rw-         14500868  Jan 31 2023 08:27:38 +01:00  cat9k-webui.17.03.06.SPA.pkg
114700  -rw-         30237704  Jan 31 2023 08:27:38 +01:00  cat9k-srdriver.17.03.06.SPA.pkg
114699  -rw-         57226244  Jan 31 2023 08:27:38 +01:00  cat9k-sipspa.17.03.06.SPA.pkg
114698  -rw-         34980872  Jan 31 2023 08:27:38 +01:00  cat9k-sipbase.17.03.06.SPA.pkg
114697  -rw-        598078468  Jan 31 2023 08:27:38 +01:00  cat9k-rpbase.17.03.06.SPA.pkg
114696  -rw-             5124  Jan 31 2023 08:27:38 +01:00  cat9k-lni.17.03.06.SPA.pkg
114695  -rw-          2262024  Jan 31 2023 08:27:38 +01:00  cat9k-guestshell.17.03.06.SPA.pkg
114694  -rw-        104670216  Jan 31 2023 08:27:38 +01:00  cat9k-espbase.17.03.06.SPA.pkg
114693  -rw-         18449420  Jan 31 2023 08:27:38 +01:00  cat9k-cc_srdriver.17.03.06.SPA.pkg
49156   drwx             4096  Jan 31 2023 08:24:07 +01:00  pnp-tech
49155   drwx             4096  Nov 23 2021 09:01:20 +01:00  .dbpersist
49163   drwx             4096  Nov 23 2021 08:56:07 +01:00  Apps
688154  -rw-             1440  Nov 23 2021 08:54:37 +01:00  2021_11_23T07_54_28.677019.xml
57345   drwx             4096  Nov 23 2021 08:49:08 +01:00  core
196609  drwx             4096  Nov 23 2021 08:48:51 +01:00  guest-share
188417  drwx             4096  Nov 23 2021 08:48:48 +01:00  pnp-info
163841  drwx             4096  Nov 23 2021 08:48:48 +01:00  onep
147457  drwx             4096  Nov 23 2021 08:43:02 +01:00  Tbot
106530  drwx             4096  Nov 23 2021 08:42:54 +01:00  sys_report
106497  drwx             4096  Nov 23 2021 08:42:53 +01:00  tech_support
65540   drwx             4096  Nov 23 2021 08:42:53 +01:00  gs_script
90113   drwx             4096  Nov 23 2021 08:42:51 +01:00  ss_disc
81921   drwx             4096  Nov 23 2021 08:42:46 +01:00  .rollback_timer

11353194496 bytes total (9614319616 bytes free)
Switch#
dir flash: sizesort

Switch#dir flash: sizesort
Directory of flash:/

114697  -rw-        598078468  Jan 31 2023 08:27:38 +01:00  cat9k-rpbase.17.03.06.SPA.pkg
114694  -rw-        104670216  Jan 31 2023 08:27:38 +01:00  cat9k-espbase.17.03.06.SPA.pkg
114699  -rw-         57226244  Jan 31 2023 08:27:38 +01:00  cat9k-sipspa.17.03.06.SPA.pkg
114703  -rw-         47422238  Jan 31 2023 08:28:37 +01:00  cat9k-rpboot.17.03.06.SPA.pkg
114698  -rw-         34980872  Jan 31 2023 08:27:38 +01:00  cat9k-sipbase.17.03.06.SPA.pkg
114700  -rw-         30237704  Jan 31 2023 08:27:38 +01:00  cat9k-srdriver.17.03.06.SPA.pkg
114693  -rw-         18449420  Jan 31 2023 08:27:38 +01:00  cat9k-cc_srdriver.17.03.06.SPA.pkg
114701  -rw-         14500868  Jan 31 2023 08:27:38 +01:00  cat9k-webui.17.03.06.SPA.pkg
688145  -rw-          5242880  Jan 31 2023 08:50:13 +01:00  ssd
114695  -rw-          2262024  Jan 31 2023 08:27:38 +01:00  cat9k-guestshell.17.03.06.SPA.pkg
688131  -rw-          2097152   Feb 1 2023 07:53:06 +01:00  nvram_config_bkup
688130  -rw-          2097152   Feb 1 2023 07:53:06 +01:00  nvram_config
688147  -rw-           134458  Jan 31 2023 08:49:57 +01:00  memleak.tcl
688149  -rw-            16976  Jan 31 2023 08:50:57 +01:00  rdope_out.txt
114702  -rw-             9220  Jan 31 2023 08:27:38 +01:00  cat9k-wlc.17.03.06.SPA.pkg
688158  -rw-             7716  Jan 31 2023 08:29:44 +01:00  packages.conf
114696  -rw-             5124  Jan 31 2023 08:27:38 +01:00  cat9k-lni.17.03.06.SPA.pkg
49163   drwx             4096  Nov 23 2021 08:56:07 +01:00  Apps
49156   drwx             4096  Jan 31 2023 08:24:07 +01:00  pnp-tech
196609  drwx             4096  Nov 23 2021 08:48:51 +01:00  guest-share
188417  drwx             4096  Nov 23 2021 08:48:48 +01:00  pnp-info
163841  drwx             4096  Nov 23 2021 08:48:48 +01:00  onep
49155   drwx             4096  Nov 23 2021 09:01:20 +01:00  .dbpersist
147457  drwx             4096  Nov 23 2021 08:43:02 +01:00  Tbot
106530  drwx             4096  Nov 23 2021 08:42:54 +01:00  sys_report
106528  drwx             4096  Jan 31 2023 08:49:42 +01:00  dc_profile_dir
106497  drwx             4096  Nov 23 2021 08:42:53 +01:00  tech_support
90113   drwx             4096  Nov 23 2021 08:42:51 +01:00  ss_disc
65540   drwx             4096  Nov 23 2021 08:42:53 +01:00  gs_script
81921   drwx             4096  Nov 23 2021 08:42:46 +01:00  .rollback_timer
65537   drwx             4096  Jan 31 2023 08:50:33 +01:00  .prst_sync
57345   drwx             4096  Nov 23 2021 08:49:08 +01:00  core
49153   drwx             4096  Jan 31 2023 08:54:22 +01:00  .installer
688148  -rwx             2049  Jan 31 2023 08:49:57 +01:00  svl_ipc.tcl
688154  -rw-             1440  Nov 23 2021 08:54:37 +01:00  2021_11_23T07_54_28.677019.xml
688152  -rw-              916  Jan 31 2023 08:50:39 +01:00  vlan.dat
688132  -rw-              382  Jan 31 2023 08:49:44 +01:00  boothelper.log
688144  -rw-              259  Jan 31 2023 08:49:33 +01:00  bootloader_evt_handle.log
688151  -rw-               89  Jan 31 2023 08:50:55 +01:00  rdope.log
688133  -rw-                0  Jan 31 2023 08:50:57 +01:00  dope_hist

11353194496 bytes total (9614319616 bytes free)
Switch#
dir system:

Switch#dir system:
Directory of system:/

    2  -r--           0                      default-running-config
    4  dr-x           0                      memory
    1  -rw-        2983                      running-config
    3  dr-x           0                      vfiles

No space information available
Switch#
dir nvram:

Switch#dir nvram:
Directory of nvram:/

7       -rw-              820                      IOS-Self-Sig#2.cer
6       ----                4                      private-KS1
5       -rw-                0                      ifIndex-table
4       -rw-              805                      CiscoLicensi#1CA.cer
3       -rw-              820                      IOS-Self-Sig#1.cer
2       -rw-               17                      ecfm_ieee_mib
1       ----              425                      persistent-data
2051    -rw-            41141                      underlying-config
2050    ----             3960                      private-config
2049    -rw-            41141                      startup-config

2097152 bytes total (2044831 bytes free)
Switch#
show flash:

Switch#show flash:
-#- --length-- ---------date/time--------- path
  2    2097152 Feb 01 2023 07:53:06.0000000000 +00:00 nvram_config
  3    2097152 Feb 01 2023 07:53:06.0000000000 +00:00 nvram_config_bkup
  4        382 Jan 31 2023 08:49:44.0000000000 +00:00 boothelper.log
  5       7716 Jan 31 2023 08:29:44.0000000000 +00:00 packages.conf
  6       4096 Jan 31 2023 08:54:22.0000000000 +00:00 .installer
  7       4096 Nov 23 2021 08:42:54.0000000000 +00:00 .installer/issu_crash
  8         14 Jan 31 2023 08:50:23.0000000000 +00:00 .installer/watchlist
  9        259 Jan 31 2023 08:49:33.0000000000 +00:00 bootloader_evt_handle.log
 10       4096 Nov 23 2021 08:49:08.0000000000 +00:00 core
 11       4096 Nov 23 2021 08:42:46.0000000000 +00:00 core/modules
 12          1 Feb 01 2023 08:20:42.0000000000 +00:00 core/.callhome
 13       4096 Jan 31 2023 08:50:33.0000000000 +00:00 .prst_sync
 14        234 Jan 31 2023 08:49:36.0000000000 +00:00 .prst_sync/log
 15         27 Jan 31 2023 08:50:42.0000000000 +00:00 .prst_sync/reload_history
 16       4096 Nov 23 2021 08:42:46.0000000000 +00:00 .rollback_timer
 17       4096 Nov 23 2021 08:42:53.0000000000 +00:00 gs_script
 18       1024 Jan 31 2023 08:49:42.0000000000 +00:00 gs_script/sss
 19      12288 Jan 31 2023 08:49:42.0000000000 +00:00 gs_script/sss/lost+found
 20    5242880 Jan 31 2023 08:50:13.0000000000 +00:00 ssd
 21       4096 Nov 23 2021 08:42:51.0000000000 +00:00 ss_disc
 22       4096 Nov 23 2021 08:42:53.0000000000 +00:00 tech_support
 23      15305 Jan 31 2023 08:49:42.0000000000 +00:00 tech_support/igmp-snooping.tcl
 24       1612 Jan 31 2023 08:49:42.0000000000 +00:00 tech_support/igmpsn_dump.tcl
 25      13515 Jan 31 2023 08:49:42.0000000000 +00:00 tech_support/mld-snooping.tcl
 26       1612 Jan 31 2023 08:49:42.0000000000 +00:00 tech_support/mldsn_dump.tcl
 27      15828 Jan 31 2023 08:49:42.0000000000 +00:00 tech_support/multicast.tcl
 28       7367 Jan 31 2023 08:49:42.0000000000 +00:00 tech_support/multicast_dump.tcl
 29       1330 Jan 31 2023 08:49:42.0000000000 +00:00 tech_support/pkt-drop-stats-dump.tcl
 30      14047 Jan 31 2023 08:49:42.0000000000 +00:00 tech_support/pkt-drop-stats.tcl
 31       1365 Jan 31 2023 08:49:42.0000000000 +00:00 tech_support/platform-fabric-iid-ethernet.tcl
 32       2107 Jan 31 2023 08:49:42.0000000000 +00:00 tech_support/platform-fabric-iid-ipv4.tcl
 33       2109 Jan 31 2023 08:49:42.0000000000 +00:00 tech_support/platform-fabric-iid-ipv6.tcl
 34       2729 Jan 31 2023 08:49:42.0000000000 +00:00 tech_support/platform-fabric-vrf-ipv4.tcl
 35       2757 Jan 31 2023 08:49:42.0000000000 +00:00 tech_support/platform-fabric-vrf-ipv6.tcl
 36      52363 Jan 31 2023 08:49:42.0000000000 +00:00 tech_support/platform-fabric-vrf-source.tcl
 37        612 Jan 31 2023 08:49:42.0000000000 +00:00 tech_support/platform-fabric.tcl
 38       1548 Jan 31 2023 08:49:42.0000000000 +00:00 tech_support/platform_evpn_vxlan.tcl
 39      26175 Jan 31 2023 08:49:42.0000000000 +00:00 tech_support/port.tcl
 40       3215 Jan 31 2023 08:49:42.0000000000 +00:00 tech_support/port_dump.tcl
 41      18827 Jan 31 2023 08:49:42.0000000000 +00:00 tech_support/port_interface.tcl
 42       8171 Jan 31 2023 08:49:42.0000000000 +00:00 tech_support/port_utils.tcl
 43      15655 Jan 31 2023 08:49:42.0000000000 +00:00 tech_support/stack.tcl
 44       4937 Jan 31 2023 08:49:42.0000000000 +00:00 tech_support/stackwise-virtual.tcl
 45       1496 Jan 31 2023 08:49:42.0000000000 +00:00 tech_support/tech-support-confidential.tcl
 46        685 Jan 31 2023 08:49:42.0000000000 +00:00 tech_support/tech-support-dump.tcl
 47      38541 Jan 31 2023 08:49:42.0000000000 +00:00 tech_support/unicast.tcl
 48      12653 Jan 31 2023 08:49:42.0000000000 +00:00 tech_support/unicast_dump.tcl
 49       5162 Jan 31 2023 08:49:42.0000000000 +00:00 tech_support/unicast_ipv6.tcl
 50       2864 Jan 31 2023 08:49:42.0000000000 +00:00 tech_support/unicast_ipv6_dump.tcl
 51        336 Jan 31 2023 08:49:42.0000000000 +00:00 tech_support/utils.tcl
 52       1384 Jan 31 2023 08:49:42.0000000000 +00:00 tech_support/xfsu.tcl
 53       4096 Jan 31 2023 08:49:42.0000000000 +00:00 dc_profile_dir
 54     293694 Jan 31 2023 08:49:42.0000000000 +00:00 dc_profile_dir/dc_default_profiles.txt
 55     293694 Jan 31 2023 08:33:47.0000000000 +00:00 dc_profile_dir/dc_default_profiles.txt.bkp
 56       4096 Nov 23 2021 08:42:54.0000000000 +00:00 sys_report
 57       4096 Nov 23 2021 08:43:07.0000000000 +00:00 .USWAP
 58       4096 Nov 23 2021 08:43:02.0000000000 +00:00 .USWAP/rp
 59       4096 Nov 23 2021 08:43:07.0000000000 +00:00 .USWAP/fp
 60       4096 Nov 23 2021 08:43:02.0000000000 +00:00 .CRFT
 61     134458 Jan 31 2023 08:49:57.0000000000 +00:00 memleak.tcl
 62       2049 Jan 31 2023 08:49:57.0000000000 +00:00 svl_ipc.tcl
 63       4096 Nov 23 2021 08:43:02.0000000000 +00:00 Tbot
 64     117906 Jan 31 2023 08:49:57.0000000000 +00:00 Tbot/HealthCheckDebugInfra.py
 65     265373 Jan 31 2023 08:49:57.0000000000 +00:00 Tbot/L3ParseOutputs.py
 66     365279 Jan 31 2023 08:49:57.0000000000 +00:00 Tbot/L3DebugInfraAPIs.py
 67     155706 Jan 31 2023 08:49:57.0000000000 +00:00 Tbot/L2DebugInfraAPIs.py
 68     164575 Jan 31 2023 08:49:57.0000000000 +00:00 Tbot/L2ParseOutputs.py
 69     155706 Jan 31 2023 08:49:57.0000000000 +00:00 Tbot/L2DebugInfraScript.py
 70       4096 Nov 23 2021 09:01:20.0000000000 +00:00 .dbpersist
 71       4096 Nov 23 2021 09:01:20.0000000000 +00:00 .dbpersist/history
 72       4096 Feb 01 2023 07:53:07.0000000000 +00:00 .dbpersist/DMI_STATE_DB
 73      14976 Feb 01 2023 07:53:07.0000000000 +00:00 .dbpersist/DMI_STATE_DB/DMI_STATE_DB
 74        173 Feb 01 2023 07:53:07.0000000000 +00:00 .dbpersist/DMI_STATE_DB/DMI_STATE_DB.meta
 75       1696 Feb 01 2023 07:53:07.0000000000 +00:00 .dbpersist/stats
 76         13 Nov 23 2021 08:43:09.0000000000 +00:00 NVRAM
 77       4096 Nov 23 2021 08:48:48.0000000000 +00:00 onep
 78       4096 Nov 23 2021 08:48:48.0000000000 +00:00 onep/apps-cli
 79       4096 Nov 23 2021 08:48:48.0000000000 +00:00 pnp-info
 80      16976 Jan 31 2023 08:50:57.0000000000 +00:00 rdope_out.txt
 81       4096 Nov 23 2021 08:48:51.0000000000 +00:00 guest-share
 82         89 Jan 31 2023 08:50:55.0000000000 +00:00 rdope.log
 83          0 Jan 31 2023 08:50:57.0000000000 +00:00 dope_hist
 84       4096 Jan 31 2023 08:24:07.0000000000 +00:00 pnp-tech
 85      15604 Jan 31 2023 08:24:07.0000000000 +00:00 pnp-tech/pnp-tech-time
 86     182263 Jan 31 2023 08:24:07.0000000000 +00:00 pnp-tech/pnp-tech-discovery-summary
 87       4096 Nov 23 2021 08:56:07.0000000000 +00:00 Apps
 88  212244480 Nov 23 2021 08:56:20.0000000000 +00:00 Apps/thousandeyes-enterprise-agent-4.0.2.cisco.tar
 89        916 Jan 31 2023 08:50:39.0000000000 +00:00 vlan.dat
 90       1440 Nov 23 2021 08:54:37.0000000000 +00:00 2021_11_23T07_54_28.677019.xml
 91   18449420 Jan 31 2023 08:27:38.0000000000 +00:00 cat9k-cc_srdriver.17.03.06.SPA.pkg
 92  104670216 Jan 31 2023 08:27:38.0000000000 +00:00 cat9k-espbase.17.03.06.SPA.pkg
 93    2262024 Jan 31 2023 08:27:38.0000000000 +00:00 cat9k-guestshell.17.03.06.SPA.pkg
 94       5124 Jan 31 2023 08:27:38.0000000000 +00:00 cat9k-lni.17.03.06.SPA.pkg
 95  598078468 Jan 31 2023 08:27:38.0000000000 +00:00 cat9k-rpbase.17.03.06.SPA.pkg
 96   47422238 Jan 31 2023 08:28:37.0000000000 +00:00 cat9k-rpboot.17.03.06.SPA.pkg
 97   34980872 Jan 31 2023 08:27:38.0000000000 +00:00 cat9k-sipbase.17.03.06.SPA.pkg
 98   57226244 Jan 31 2023 08:27:38.0000000000 +00:00 cat9k-sipspa.17.03.06.SPA.pkg
 99   30237704 Jan 31 2023 08:27:38.0000000000 +00:00 cat9k-srdriver.17.03.06.SPA.pkg
100   14500868 Jan 31 2023 08:27:38.0000000000 +00:00 cat9k-webui.17.03.06.SPA.pkg
101       9220 Jan 31 2023 08:27:38.0000000000 +00:00 cat9k-wlc.17.03.06.SPA.pkg
9614319616 bytes available (1162158080 bytes used)

Switch#
show flash: sizesort

Switch#show flash: sizesort
-#- --length-- ---------date/time--------- path
    95  598078468 Jan 31 2023 08:27:38.0000000000 +00:00 cat9k-rpbase.17.03.06.SPA.pkg
    88  212244480 Nov 23 2021 08:56:20.0000000000 +00:00 Apps/thousandeyes-enterprise-agent-4.0.2.cisco.tar
    92  104670216 Jan 31 2023 08:27:38.0000000000 +00:00 cat9k-espbase.17.03.06.SPA.pkg
    98   57226244 Jan 31 2023 08:27:38.0000000000 +00:00 cat9k-sipspa.17.03.06.SPA.pkg
    96   47422238 Jan 31 2023 08:28:37.0000000000 +00:00 cat9k-rpboot.17.03.06.SPA.pkg
    97   34980872 Jan 31 2023 08:27:38.0000000000 +00:00 cat9k-sipbase.17.03.06.SPA.pkg
    99   30237704 Jan 31 2023 08:27:38.0000000000 +00:00 cat9k-srdriver.17.03.06.SPA.pkg
    91   18449420 Jan 31 2023 08:27:38.0000000000 +00:00 cat9k-cc_srdriver.17.03.06.SPA.pkg
   100   14500868 Jan 31 2023 08:27:38.0000000000 +00:00 cat9k-webui.17.03.06.SPA.pkg
    20    5242880 Jan 31 2023 08:50:13.0000000000 +00:00 ssd
    93    2262024 Jan 31 2023 08:27:38.0000000000 +00:00 cat9k-guestshell.17.03.06.SPA.pkg
     2    2097152 Feb 01 2023 07:53:06.0000000000 +00:00 nvram_config
     3    2097152 Feb 01 2023 07:53:06.0000000000 +00:00 nvram_config_bkup
    66     365279 Jan 31 2023 08:49:57.0000000000 +00:00 Tbot/L3DebugInfraAPIs.py
    54     293694 Jan 31 2023 08:49:42.0000000000 +00:00 dc_profile_dir/dc_default_profiles.txt
    55     293694 Jan 31 2023 08:33:47.0000000000 +00:00 dc_profile_dir/dc_default_profiles.txt.bkp
    65     265373 Jan 31 2023 08:49:57.0000000000 +00:00 Tbot/L3ParseOutputs.py
    86     182263 Jan 31 2023 08:24:07.0000000000 +00:00 pnp-tech/pnp-tech-discovery-summary
    68     164575 Jan 31 2023 08:49:57.0000000000 +00:00 Tbot/L2ParseOutputs.py
    67     155706 Jan 31 2023 08:49:57.0000000000 +00:00 Tbot/L2DebugInfraAPIs.py
    69     155706 Jan 31 2023 08:49:57.0000000000 +00:00 Tbot/L2DebugInfraScript.py
    61     134458 Jan 31 2023 08:49:57.0000000000 +00:00 memleak.tcl
    64     117906 Jan 31 2023 08:49:57.0000000000 +00:00 Tbot/HealthCheckDebugInfra.py
    36      52363 Jan 31 2023 08:49:42.0000000000 +00:00 tech_support/platform-fabric-vrf-source.tcl
    47      38541 Jan 31 2023 08:49:42.0000000000 +00:00 tech_support/unicast.tcl
    39      26175 Jan 31 2023 08:49:42.0000000000 +00:00 tech_support/port.tcl
    41      18827 Jan 31 2023 08:49:42.0000000000 +00:00 tech_support/port_interface.tcl
    80      16976 Jan 31 2023 08:50:57.0000000000 +00:00 rdope_out.txt
    27      15828 Jan 31 2023 08:49:42.0000000000 +00:00 tech_support/multicast.tcl
    43      15655 Jan 31 2023 08:49:42.0000000000 +00:00 tech_support/stack.tcl
    85      15604 Jan 31 2023 08:24:07.0000000000 +00:00 pnp-tech/pnp-tech-time
    23      15305 Jan 31 2023 08:49:42.0000000000 +00:00 tech_support/igmp-snooping.tcl
    73      14976 Feb 01 2023 07:53:07.0000000000 +00:00 .dbpersist/DMI_STATE_DB/DMI_STATE_DB
    30      14047 Jan 31 2023 08:49:42.0000000000 +00:00 tech_support/pkt-drop-stats.tcl
    25      13515 Jan 31 2023 08:49:42.0000000000 +00:00 tech_support/mld-snooping.tcl
    48      12653 Jan 31 2023 08:49:42.0000000000 +00:00 tech_support/unicast_dump.tcl
    19      12288 Jan 31 2023 08:49:42.0000000000 +00:00 gs_script/sss/lost+found
   101       9220 Jan 31 2023 08:27:38.0000000000 +00:00 cat9k-wlc.17.03.06.SPA.pkg
    42       8171 Jan 31 2023 08:49:42.0000000000 +00:00 tech_support/port_utils.tcl
     5       7716 Jan 31 2023 08:29:44.0000000000 +00:00 packages.conf
    28       7367 Jan 31 2023 08:49:42.0000000000 +00:00 tech_support/multicast_dump.tcl
    49       5162 Jan 31 2023 08:49:42.0000000000 +00:00 tech_support/unicast_ipv6.tcl
    94       5124 Jan 31 2023 08:27:38.0000000000 +00:00 cat9k-lni.17.03.06.SPA.pkg
    44       4937 Jan 31 2023 08:49:42.0000000000 +00:00 tech_support/stackwise-virtual.tcl
     6       4096 Jan 31 2023 08:54:22.0000000000 +00:00 .installer
     7       4096 Nov 23 2021 08:42:54.0000000000 +00:00 .installer/issu_crash
    10       4096 Nov 23 2021 08:49:08.0000000000 +00:00 core
    11       4096 Nov 23 2021 08:42:46.0000000000 +00:00 core/modules
    13       4096 Jan 31 2023 08:50:33.0000000000 +00:00 .prst_sync
    16       4096 Nov 23 2021 08:42:46.0000000000 +00:00 .rollback_timer
    17       4096 Nov 23 2021 08:42:53.0000000000 +00:00 gs_script
    21       4096 Nov 23 2021 08:42:51.0000000000 +00:00 ss_disc
    22       4096 Nov 23 2021 08:42:53.0000000000 +00:00 tech_support
    53       4096 Jan 31 2023 08:49:42.0000000000 +00:00 dc_profile_dir
    56       4096 Nov 23 2021 08:42:54.0000000000 +00:00 sys_report
    57       4096 Nov 23 2021 08:43:07.0000000000 +00:00 .USWAP
    58       4096 Nov 23 2021 08:43:02.0000000000 +00:00 .USWAP/rp
    59       4096 Nov 23 2021 08:43:07.0000000000 +00:00 .USWAP/fp
    60       4096 Nov 23 2021 08:43:02.0000000000 +00:00 .CRFT
    63       4096 Nov 23 2021 08:43:02.0000000000 +00:00 Tbot
    70       4096 Nov 23 2021 09:01:20.0000000000 +00:00 .dbpersist
    71       4096 Nov 23 2021 09:01:20.0000000000 +00:00 .dbpersist/history
    72       4096 Feb 01 2023 07:53:07.0000000000 +00:00 .dbpersist/DMI_STATE_DB
    77       4096 Nov 23 2021 08:48:48.0000000000 +00:00 onep
    78       4096 Nov 23 2021 08:48:48.0000000000 +00:00 onep/apps-cli
    79       4096 Nov 23 2021 08:48:48.0000000000 +00:00 pnp-info
    81       4096 Nov 23 2021 08:48:51.0000000000 +00:00 guest-share
    84       4096 Jan 31 2023 08:24:07.0000000000 +00:00 pnp-tech
    87       4096 Nov 23 2021 08:56:07.0000000000 +00:00 Apps
    40       3215 Jan 31 2023 08:49:42.0000000000 +00:00 tech_support/port_dump.tcl
    50       2864 Jan 31 2023 08:49:42.0000000000 +00:00 tech_support/unicast_ipv6_dump.tcl
    35       2757 Jan 31 2023 08:49:42.0000000000 +00:00 tech_support/platform-fabric-vrf-ipv6.tcl
    34       2729 Jan 31 2023 08:49:42.0000000000 +00:00 tech_support/platform-fabric-vrf-ipv4.tcl
    33       2109 Jan 31 2023 08:49:42.0000000000 +00:00 tech_support/platform-fabric-iid-ipv6.tcl
    32       2107 Jan 31 2023 08:49:42.0000000000 +00:00 tech_support/platform-fabric-iid-ipv4.tcl
    62       2049 Jan 31 2023 08:49:57.0000000000 +00:00 svl_ipc.tcl
    75       1696 Feb 01 2023 07:53:07.0000000000 +00:00 .dbpersist/stats
    24       1612 Jan 31 2023 08:49:42.0000000000 +00:00 tech_support/igmpsn_dump.tcl
    26       1612 Jan 31 2023 08:49:42.0000000000 +00:00 tech_support/mldsn_dump.tcl
    38       1548 Jan 31 2023 08:49:42.0000000000 +00:00 tech_support/platform_evpn_vxlan.tcl
    45       1496 Jan 31 2023 08:49:42.0000000000 +00:00 tech_support/tech-support-confidential.tcl
    90       1440 Nov 23 2021 08:54:37.0000000000 +00:00 2021_11_23T07_54_28.677019.xml
    52       1384 Jan 31 2023 08:49:42.0000000000 +00:00 tech_support/xfsu.tcl
    31       1365 Jan 31 2023 08:49:42.0000000000 +00:00 tech_support/platform-fabric-iid-ethernet.tcl
    29       1330 Jan 31 2023 08:49:42.0000000000 +00:00 tech_support/pkt-drop-stats-dump.tcl
    18       1024 Jan 31 2023 08:49:42.0000000000 +00:00 gs_script/sss
    89        916 Jan 31 2023 08:50:39.0000000000 +00:00 vlan.dat
    46        685 Jan 31 2023 08:49:42.0000000000 +00:00 tech_support/tech-support-dump.tcl
    37        612 Jan 31 2023 08:49:42.0000000000 +00:00 tech_support/platform-fabric.tcl
     4        382 Jan 31 2023 08:49:44.0000000000 +00:00 boothelper.log
    51        336 Jan 31 2023 08:49:42.0000000000 +00:00 tech_support/utils.tcl
     9        259 Jan 31 2023 08:49:33.0000000000 +00:00 bootloader_evt_handle.log
    14        234 Jan 31 2023 08:49:36.0000000000 +00:00 .prst_sync/log
    74        173 Feb 01 2023 07:53:07.0000000000 +00:00 .dbpersist/DMI_STATE_DB/DMI_STATE_DB.meta
    82         89 Jan 31 2023 08:50:55.0000000000 +00:00 rdope.log
    15         27 Jan 31 2023 08:50:42.0000000000 +00:00 .prst_sync/reload_history
     8         14 Jan 31 2023 08:50:23.0000000000 +00:00 .installer/watchlist
    76         13 Nov 23 2021 08:43:09.0000000000 +00:00 NVRAM
    12          1 Feb 01 2023 08:20:42.0000000000 +00:00 core/.callhome
    83          0 Jan 31 2023 08:50:57.0000000000 +00:00 dope_hist
9614319616 bytes available (1162158080 bytes used)
Switch#

USB Flash Directory

Cisco IOS is able to use the same concept explained above for USB flash thumbdrives.

Description
Display the USB flash file directory
Display the USB flash file directory
Display the USB flash file directory and sort the content by name
Display the USB flash file directory and sort the content by size
CLI Commands
show usbflash0:
dir usbflash0:
dir usbflash0: sizesort
dir usbflash0: namesort

Configuration Memory

The user can use the "copy running-config startup-config" command to save the current configuration to the non-volatile storage. The "startup-config" file contains the configuration that will be used by the device when it is started. It is a good idea to save the configuration changes regularly, especially before making major changes. This way, if something goes wrong, the user can easily revert back to a working configuration. The user can also use the "write" or "write memory" command as an alternative. This command performs the same function.

Description
Save the current system configuration
Delete the system configuration
Delete the system configuration
Delete the configured VLAN table
Save the current system configuration
Overwrite the current configuration with the last saved configuration
Display the current configuration
Display the last saved configuration
Delete the last saved configuration
CLI Commands
write
write erase
factory-reset config
delete vlan.dat
copy running-config startup-config
copy startup-config running-config
show running-configuration
show startup-configuration
erase startup-configuration
write

Switch#
Switch#write
Building configuration...
Compressed configuration from 1695 bytes to 888 bytes[OK]
Switch#
*Jan 30 13:31:59.965: %GRUB-5-CONFIG_WRITING: GRUB configuration is being updated on disk. Please wait...
*Jan 30 13:32:00.640: %GRUB-5-CONFIG_WRITTEN: GRUB configuration was written to disk successfully.
Switch#
write erase

Switch#write erase
Erasing the nvram filesystem will remove all configuration files! Continue? [confirm]
[OK]
Erase of nvram: complete
Switch#
*Jan 30 15:33:46.373: %SYS-7-NV_BLOCK_INIT: Initialized the geometry of nvram
Switch#
Switch#reload
Proceed with reload? [confirm]

*Jan 30 15:34:35.332: %SYS-5-RELOAD: Reload requested by console. Reload Reason: Reload command.
factory-reset config

Switch#factory-reset config
The factory reset operation is irreversible for erasing configuration. Are you sure? [confirm]
 As part of this operation Config and FIPS Key (if detected) will be removed.
 Make sure to configure it back to enable FIPS mode.
 Are you sure you want to continue? [confirm]
Switch#
*Feb  1 07:31:54.164: NGWC_FACTORYRESET: Switch 1, cmd: clear config success
*Feb  1 07:31:54.307: %SYS-7-NV_BLOCK_INIT: Initialized the geometry of nvram
Switch#
delete vlan.dat

Switch#
Switch#delete vlan.dat
Delete filename [vlan.dat]?
Delete flash:/vlan.dat? [confirm]
Switch#
Switch#show run vlan
Building configuration...

Current configuration:
end

Switch#
show running-config

Switch#show run
Building configuration...

Current configuration : 9481 bytes
!
! Last configuration change at 07:52:05 UTC Wed Feb 1 2023
!
version 17.3
service timestamps debug datetime msec
service timestamps log datetime msec
! Call-home is enabled by Smart-Licensing.
service call-home
platform punt-keepalive disable-kernel-core
!
hostname Switch
!
!
vrf definition Mgmt-vrf
 !
 address-family ipv4
 exit-address-family
 !
 address-family ipv6
 exit-address-family
!
!
no aaa new-model
switch 1 provision c9300-24p
!
!
!
!
!
!
!
!
!
!
ip dhcp pool webuidhcp
!
!
!
login on-success log
ipv6 unicast-routing
!
!
!
!
!
!
!
no device-tracking logging theft
!
crypto pki trustpoint SLA-TrustPoint
 enrollment pkcs12
 revocation-check crl
!
crypto pki trustpoint TP-self-signed-3704575809
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-3704575809
 revocation-check none
 rsakeypair TP-self-signed-3704575809
!
!
crypto pki certificate chain SLA-TrustPoint
 certificate ca 01
  30820321 30820209 A0030201 02020101 300D0609 2A864886 F70D0101 0B050030
  32310E30 0C060355 040A1305 43697363 6F312030 1E060355 04031317 43697363
  6F204C69 63656E73 696E6720 526F6F74 20434130 1E170D31 33303533 30313934
  3834375A 170D3338 30353330 31393438 34375A30 32310E30 0C060355 040A1305
  43697363 6F312030 1E060355 04031317 43697363 6F204C69 63656E73 696E6720
  526F6F74 20434130 82012230 0D06092A 864886F7 0D010101 05000382 010F0030
  82010A02 82010100 A6BCBD96 131E05F7 145EA72C 2CD686E6 17222EA1 F1EFF64D
  CBB4C798 212AA147 C655D8D7 9471380D 8711441E 1AAF071A 9CAE6388 8A38E520
  1C394D78 462EF239 C659F715 B98C0A59 5BBB5CBD 0CFEBEA3 700A8BF7 D8F256EE
  4AA4E80D DB6FD1C9 60B1FD18 FFC69C96 6FA68957 A2617DE7 104FDC5F EA2956AC
  7390A3EB 2B5436AD C847A2C5 DAB553EB 69A9A535 58E9F3E3 C0BD23CF 58BD7188
  68E69491 20F320E7 948E71D7 AE3BCC84 F10684C7 4BC8E00F 539BA42B 42C68BB7
  C7479096 B4CB2D62 EA2F505D C7B062A4 6811D95B E8250FC4 5D5D5FB8 8F27D191
  C55F0D76 61F9A4CD 3D992327 A8BB03BD 4E6D7069 7CBADF8B DF5F4368 95135E44
  DFC7C6CF 04DD7FD1 02030100 01A34230 40300E06 03551D0F 0101FF04 04030201
  06300F06 03551D13 0101FF04 05300301 01FF301D 0603551D 0E041604 1449DC85
  4B3D31E5 1B3E6A17 606AF333 3D3B4C73 E8300D06 092A8648 86F70D01 010B0500
  03820101 00507F24 D3932A66 86025D9F E838AE5C 6D4DF6B0 49631C78 240DA905
  604EDCDE FF4FED2B 77FC460E CD636FDB DD44681E 3A5673AB 9093D3B1 6C9E3D8B
  D98987BF E40CBD9E 1AECA0C2 2189BB5C 8FA85686 CD98B646 5575B146 8DFC66A8
  467A3DF4 4D565700 6ADF0F0D CF835015 3C04FF7C 21E878AC 11BA9CD2 55A9232C
  7CA7B7E6 C1AF74F6 152E99B7 B1FCF9BB E973DE7F 5BDDEB86 C71E3B49 1765308B
  5FB0DA06 B92AFE7F 494E8A9E 07B85737 F3A58BE1 1A48A229 C37C1E69 39F08678
  80DDCD16 D6BACECA EEBC7CF9 8428787B 35202CDC 60E4616A B623CDBD 230E3AFB
  418616A9 4093E049 4D10AB75 27E86F73 932E35B5 8862FDAE 0275156F 719BB2F0
  D697DF7F 28
        quit
crypto pki certificate chain TP-self-signed-3704575809
 certificate self-signed 01
  30820330 30820218 A0030201 02020101 300D0609 2A864886 F70D0101 05050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 33373034 35373538 3039301E 170D3233 30323031 30373532
  30355A17 0D333330 31333130 37353230 355A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D33 37303435
  37353830 39308201 22300D06 092A8648 86F70D01 01010500 0382010F 00308201
  0A028201 0100F5E9 78AE90F0 5132DDE2 04CF2700 4C63361A 6A121903 54408DF7
  8BA868C0 E552757F 9447A826 443F8665 36263B5E 47B38512 AADE2B3A C6A3DB9E
  CC8C11AC 4C48ABC2 F144A2A8 84A5016C EAB18746 C9096131 53D85DB4 E1FB35CF
  02BDAAE9 0456190C 27AE41AF 6856F4DF 0316D4A2 571D2398 FDF3A33A 66B5E8D6
  9D4F7B6B 8FD1245A 45FE91A9 B5FDCBC8 315444CC D44B8787 4DBF9978 77D02596
  32847C51 7773A8DA 246A3411 888508DB 550EA80F 1083780D 99C21D82 002D685D
  A3BC28E1 2C2F759B 3E738B9A 23EC6DB5 8D372426 EFB13F54 350AE153 5876EA99
  E68B1916 C2A0DBA6 75411C97 89282D91 BD0AB596 1339B746 2670EED9 A9BC0BF4
  0A79BE79 1D070203 010001A3 53305130 0F060355 1D130101 FF040530 030101FF
  301F0603 551D2304 18301680 1449C515 BA2E5883 5577AE95 74FA621F 0EB56F27
  49301D06 03551D0E 04160414 49C515BA 2E588355 77AE9574 FA621F0E B56F2749
  300D0609 2A864886 F70D0101 05050003 82010100 ABC30599 055E38E1 438863ED
  E1516BC0 79F0FF6A D501D6ED 6607F1C4 03AD7CF2 BE7543D4 94A8B7DB 8E512C62
  5AFEF93F AA2531BF A285C87D F1FC8404 E5324034 6684C82A A90EE064 1CF374FB
  FDBB5C72 2DC15CF7 4B0F88E5 AA58D0DA 648AAB48 426D2AC5 6AAC26DD 2129032E
  CFAFF9BE 61F9FF41 3681193E AE5064E9 7B3A9D6E 551EAAED 1771D659 B334EF33
 --More--
*Feb  1 07:52:17.767: %SYS-5-CONFIG_P: Configured programmatically by process PnP Agent Discovery from console as vty                                                                                                                        0
*Feb  1 07:52:17.767: %PNP-6-PNP_SAVING_TECH_SUMMARY: Saving PnP tech summary (/pnp-tech/pnp-tech-discovery-summary).                                                                                                                        .. Please wait. Do not   9E6E41F5 E5A82650 20A5132F D422A11C 8786AD74 8BFBC576 6FAF3D2B E695E418
  72A64E31 717030EB 2756641E FE8DB41A FE9C45AD 9DDE8E12 C36009B5 F549BB50
  DF9F15C5 982997AD 4A953340 A2FC683B 33DFA6B3 CF724216 7ADE78B6 3BF8A771
  E2D1BD1D 790C82FD 813F2320 444442B6 3FDC3B4C
        quit
!
!
license boot level network-advantage addon dna-advantage
!
!
diagnostic bootup level minimal
!
spanning-tree mode rapid-pvst
spanning-tree extend system-id
memory free low-watermark processor 133103
!
!
redundancy
 mode sso
!
!
!
!
 --More--
*Feb  1 07:52:17.889: %SYS-5-CONFIG_P: Configured programmatically by process PnP Agent Discovery from console as vty                                                                                                                        0
*Feb  1 07:52:18.138: %SYS-5-CONFIG_P: Configured programmatically by process PnP Agent Discovery from console as vty                                                                                                                        0
*Feb  1 07:52:18.285: %SYS-5-CONFIG_P: Configured programmatically by process PnP Agent Discovery from console as vty                                                                                                                        0
*Feb  1 07:52:18.547: %SYS-5-CONFIG_P: Configured programmatically by process PnP Agent Discovery from console as vty                                                                                                                        0
*Feb  1 07:52:18.664: %PNP-6-PNP_SUDI_UPDATE: Device SUDI [PID:C9300-24P,SN:FCW2323G00Q] identified
*Feb  1 07:52:18.882: %SYS-5-CONFIG_P: Configured programmatically by process PnP Agent Discovery from console as vty                                                                                                                        0
*Feb  1 07:52:18.987: %PNP-6-PNP_TECH_SUMMARY_SAVED_OK: PnP tech summary (/pnp-tech/pnp-tech-discovery-summary) saved                                                                                                                         successfully (elapsed time: 1 seconds).
*Feb  1 07:52:18.987: %PNP-6-PNP_DISCOVERY_STOPPED: PnP Discovery stopped (Conf!        )
!
transceiver type all
 monitoring
!
!
class-map match-any system-cpp-police-ewlc-control
  description EWLC Control
class-map match-any system-cpp-police-topology-control
  description Topology control
class-map match-any system-cpp-police-sw-forward
  description Sw forwarding, L2 LVX data packets, LOGGING, Transit Traffic
class-map match-any system-cpp-default
  description EWLC Data, Inter FED Traffic
class-map match-any system-cpp-police-sys-data
  description Openflow, Exception, EGR Exception, NFL Sampled Data, RPF Failed
class-map match-any system-cpp-police-punt-webauth
  description Punt Webauth
class-map match-any system-cpp-police-l2lvx-control
  description L2 LVX control packets
class-map match-any system-cpp-police-forus
  description Forus Address resolution and Forus traffic
class-map match-any system-cpp-police-multicast-end-station
 --More--
*Feb  1 07:52:20.764: %IOXN_APP-6-PRE_INIT_DAY0_GS_INFO: Day0 Guestshell de-initilization API is being invo  descript                                                                                                                        ion MCAST END STATION
class-map match-any system-cpp-police-high-rate-app
  description High Rate Applications
class-map match-any system-cpp-police-multicast
  description MCAST Data
class-map match-any system-cpp-police-l2-control
  description L2 control
class-map match-any system-cpp-police-dot1x-auth
  description DOT1X Auth
class-map match-any system-cpp-police-data
  description ICMP redirect, ICMP_GEN and BROADCAST
class-map match-any system-cpp-police-stackwise-virt-control
  description Stackwise Virtual OOB
class-map match-any non-client-nrt-class
class-map match-any system-cpp-police-routing-control
  description Routing control and Low Latency
class-map match-any system-cpp-police-protocol-snooping
  description Protocol snooping
class-map match-any system-cpp-police-dhcp-snooping
  description DHCP snooping
class-map match-any system-cpp-police-ios-routing
  description L2 control, Topology control, Routing control, Low Latency
class-map match-any system-cpp-police-system-critical
  description System Critical and Gold Pkt
class-map match-any system-cpp-police-ios-feature
  description ICMPGEN,BROADCAST,ICMP,L2LVXCntrl,ProtoSnoop,PuntWebauth,MCASTData,Transit,DOT1XAuth,Swfwd,LOGGING,L2LV                                                                                                                        XData,ForusTraffic,ForusARP,McastEndStn,Openflow,Exception,EGRExcption,NflSampled,RpfFailed
!
policy-map system-cpp-policy
!
!
!
!
!
!
!
!
!
!
!
!
interface GigabitEthernet0/0
 vrf forwarding Mgmt-vrf
 no ip address
 shutdown
 negotiation auto
!
interface GigabitEthernet1/0/1
!
interface GigabitEthernet1/0/2
!
interface GigabitEthernet1/0/3
!
interface GigabitEthernet1/0/4
!
interface GigabitEthernet1/0/5
!
interface GigabitEthernet1/0/6
!
interface GigabitEthernet1/0/7
!
interface GigabitEthernet1/0/8
!
interface GigabitEthernet1/0/9
!
interface GigabitEthernet1/0/10
!
interface GigabitEthernet1/0/11
!
interface GigabitEthernet1/0/12
!
interface GigabitEthernet1/0/13
!
interface GigabitEthernet1/0/14
!
interface GigabitEthernet1/0/15
!
interface GigabitEthernet1/0/16
!
interface GigabitEthernet1/0/17
!
interface GigabitEthernet1/0/18
!
interface GigabitEthernet1/0/19
!
interface GigabitEthernet1/0/20
!
interface GigabitEthernet1/0/21
!
interface GigabitEthernet1/0/22
!
interface GigabitEthernet1/0/23
!
interface GigabitEthernet1/0/24
!
interface GigabitEthernet1/1/1
!
interface GigabitEthernet1/1/2
!
interface GigabitEthernet1/1/3
!
interface GigabitEthernet1/1/4
!
interface TenGigabitEthernet1/1/1
!
interface TenGigabitEthernet1/1/2
!
interface TenGigabitEthernet1/1/3
!
interface TenGigabitEthernet1/1/4
!
interface TenGigabitEthernet1/1/5
!
interface TenGigabitEthernet1/1/6
!
interface TenGigabitEthernet1/1/7
!
interface TenGigabitEthernet1/1/8
!
interface FortyGigabitEthernet1/1/1
!
interface FortyGigabitEthernet1/1/2
!
interface TwentyFiveGigE1/1/1
!
interface TwentyFiveGigE1/1/2
!
interface AppGigabitEthernet1/0/1
!
interface Vlan1
 no ip address
 shutdown
!
ip forward-protocol nd
ip http server
ip http authentication local
ip http secure-server
!
!
!
!
!
!
control-plane
 service-policy input system-cpp-policy
!
!
line con 0
 stopbits 1
line vty 0 4
 login
 transport input ssh
line vty 5 31
 login
 transport input ssh
!
call-home
 ! If contact email address in call-home is configured as sch-smart-licensing@cisco.com
 ! the email address configured in Cisco Smart License Portal will be used as contact email address to send SCH notif                                                                                                                        ications.
 contact-email-addr sch-smart-licensing@cisco.com
 profile "CiscoTAC-1"
  active
  destination transport-method http
!
!
!
!
!
!
end

Switch#

Premium Access

Log in or register - Premium members can access all content without restrictions.

Get Premium

0 Comments

Submit a Comment